Recently a number of you have asked this question. Since the jQuery version of the product relies on multiple third party plugins, upgrading the jQuery version of the product means that you have to upgrade some of the plugins as well, in addition to the grid scripts. The one such plugin that we use that you will need to upgrade is the excellent masked textinput plugin by digital bush. You simply have to replace this line:
   <script type="text/javascript" src=" http://www.htmltreegrid.com/demo/ external/js/adapters/jquery/jquery.maskedinput-1.3.js"></script>
With this:

    <script type="text/javascript" src=" http://www.htmltreegrid.com/demo/ external/js/adapters/jquery/jquery.maskedinput-1.3.1.js "></script>

The second thing to do is to get the latest jQuery build from us. We have eliminated the dependencies on the deprecated bits.

The other thing you could also do, if you do not wish to change the URLS, is to add this snippet of code right after your jQuery import:

<script type="text/javascript">
        (function () {
            if (!jQuery.browser) {
                var matched, browser;
                var matchFunction = function (ua) {
                    ua = ua.toLowerCase();
                    var match = /(chrome)[ \/]([\w.]+)/.exec(ua) ||

                    /(webkit)[ \/]([\w.]+)/.exec(ua) ||
                    /(opera)(?:.*version|)[ \/]([\w.]+)/.exec(ua) ||
                    /(msie) ([\w.]+)/.exec(ua) ||
                    ua.indexOf("compatible") < 0 && /(mozilla)(?:.*? rv:([\w.]+)|)/.exec(ua) || [];
                    return {
                        browser: match[1] || "",
                        version: match[2] || "0"
                    };
                };
                matched = matchFunction(navigator.userAgent);
                browser = {};
                if (matched.browser) {
                    browser[matched.browser] = true;
                    browser.version = matched.version;
                }
                if (browser.chrome) {
                    browser.webkit = true;
                } else if (browser.webkit) {
                    browser.safari = true;
                }
                jQuery.browser = browser;
            }

        })();

</script>